Tacticular Cancer: We'll have your balls

  1. Welcome to rpgcodex.net, a site dedicated to discussing computer based role-playing games in a free and open fashion. We're less strict than other forums, but please refer to the rules.

    "This message is awaiting moderator approval": All new users must pass through our moderation queue before they will be able to post normally. Until your account has "passed" your posts will only be visible to yourself (and moderators) until they are approved. Give us a week to get around to approving / deleting / ignoring your mundane opinion on crap before hassling us about it. Once you have passed the moderation period (think of it as a test), you will be able to post normally, just like all the other retards.
    Dismiss Notice

Teudogar, how to get rid of the messed up colors?

Discussion in 'Teudogar and the Alliance with Rome' started by Humanity has risen!, Jul 16, 2011.

  1. Make America Great Again Humanity has risen! Arcane Patron Repressed Homosexual

    Humanity has risen!
    Joined:
    Mar 29, 2010
    Parrots:
    11,705
    Location:
    Ottawa, Can.
    Click here and disable ads!
    I reckon that it's probably a DirectDraw issue, but is there some sort of working hack out there that could be implemented? I read that people did it for other games.

    Also does the combat ever get better? I hope it's not just two guys facing each other and hitting the attack button over and over again to throw a dice roll until someone has low HP.
     
    ^ Top  
  2. Adam P Augur

    Adam P
    Joined:
    Oct 10, 2004
    Parrots:
    63
    Location:
    Silly American
    Sorry for the delay, I'm not really sure what problem you are referring to. It may have been mentioned here, you might take a gander. Otherwise if you are more specific maybe we can figure it out.
    By now I think you'll probably have noticed that yes the combat does get more advanced. Between the various weaponry and curses and blessings. It really does get quite intricate. Though, at times the curses can feel a bit overpowered. IMO
     
    ^ Top  
  3. Wolf Mittag Liturgist

    Wolf Mittag
    Joined:
    Dec 18, 2003
    Parrots:
    331
    Location:
    Shanghai
    Sorry for my quite terrible delay in replying. Yes, Teudogar uses a very, very old-fashioned 8 bit 256 colour palettized graphics mode, and in some constellations Windows messes up the colour palette.

    I'm currently working on porting Teudogar to 16 or 32 bit non-palettized truecolor mode, and will make free updates available when done. But there are some things that will take a bit more work, including that the day/night/light system is based on palette modification, and thus will have to be rewritten to use a different method under truecolor.

    Meanwhile, in order to avoid the colour problem with the present Teudogar version, you can close all other applications (particularly Windows Explorer in Thumbnail Preview Mode or Windows Media Player) before running Teudogar; also, close all widgets, clocks, tool bars, or whatever else is on your desktop that might get updated (if anything gets updated and output anywhere, Windows (esp Vista or 7) will tend to mess up Teudogar's palette (ignoring that, with Teudogar being in exclusive full screen mode, there's nothing to output and thus no need to mess with the palette; but, well, that's Microsoft). You might even hide the taskbar. With really nothing else left to output or to even consider for output but Teudogar, Windows should leave the colours alone.

    Second, whenever the problem occurs, you can fix it by briefly pressing ALT+TAB, which will return you to the Windows Desktop, and then pressing ALT+TAB again, which will return you to Teudogar, which will then reload the graphics and the colour palette, thereby fixing any messed up colours.

    I hope these suggestions help, at least until I finally release an update.
     
    ^ Top  
  4. Gragt Arcane Patron

    Gragt
    Joined:
    Nov 1, 2007
    Parrots:
    1,864,557
    Location:
    Dans Ton Cul
    Serpent in the Staglands Divinity: Original Sin
    ^ Top  
  5. Make America Great Again Humanity has risen! Arcane Patron Repressed Homosexual

    Humanity has risen!
    Joined:
    Mar 29, 2010
    Parrots:
    11,705
    Location:
    Ottawa, Can.
    I remember after posting the thread that I then tried that utility, but it did nothing.

    Anyway I got a new laptop since then, and tried to run Teudogar on it, and the problem didn't appear again.

    After reading your explanation Wolf, it's probably because I now only use Windows when I want to play a game, and use Linux for everything else, so there are no residual programs in memory which could interfere with the game's color display.
     
    ^ Top  
  6. Make America Great Again Commissar Draco KKKodex WCDS Commissar Patron

    Commissar Draco
    Joined:
    Mar 6, 2011
    Parrots:
    13,180
    Location:
    Best Russia
    Divinity: Original Sin Project: Eternity Torment: Tides of Numenera Wasteland 2 Divinity: Original Sin 2
    Got same problem as HHR did with messed up colors under Windows 7 64b, awaiting the patch. :salute:
     
    ^ Top  
  7. groke Arcane Patron

    groke
    Joined:
    Dec 28, 2011
    Parrots:
    2,104
    Location:
    SAVE THIS CHARACTER? NO.
    Codex 2013 Codex 2014 PC RPG Website of the Year, 2015 Codex 2016 - The Age of Grimoire Serpent in the Staglands Divinity: Original Sin Torment: Tides of Numenera BattleTech
    Almost certainly, it'll be Aero fucking it up. Switch you theme to "Basic" and try it again, or just kill explorer.exe after you start the game and run it again when you're done.
     
    ^ Top  
  8. visions Magister

    visions
    Joined:
    Jun 10, 2007
    Parrots:
    1,513
    Location:
    here
    Can't be Aero, I have the same problem on my laptop running XP.
     
    ^ Top  
  9. groke Arcane Patron

    groke
    Joined:
    Dec 28, 2011
    Parrots:
    2,104
    Location:
    SAVE THIS CHARACTER? NO.
    Codex 2013 Codex 2014 PC RPG Website of the Year, 2015 Codex 2016 - The Age of Grimoire Serpent in the Staglands Divinity: Original Sin Torment: Tides of Numenera BattleTech
    Did you try killing the explorer process, anyway?
     
    ^ Top  
  10. Wolf Mittag Liturgist

    Wolf Mittag
    Joined:
    Dec 18, 2003
    Parrots:
    331
    Location:
    Shanghai
    Closing all other applications, setting the desktop background to blank, hiding the clock and taskbar etc will all work somewhat, but Windows will usually still manage to mess up at least some colours.

    A quirky but surprisingly effective workaround seems to be to keep Windows' Set Display Resolution Window open in the background while you are playing Teudogar:

    Go to Start Menu, Control Panel, Display, and click on Adjust Resolution (in German: Systemsteuerung, Bildschirm, Auflösung). Keep the Set Resolution Window open.

    With the Set Resolution Windows still open, start Teudogar via start menu and play. As the Set Resolution Window apparently tells Windows not to mess with the graphics for the time being, Teudogar (and other old palettized 256-colours games) should now work without their screen colours becoming messed up.

    (If there are still problems, ALT+TAB back+forth to the Set Resolution Window; maybe change the resolution; but keep the Set Resolution Window open; ALT+TAB back to Teudogar.)
     
    • Brofist Brofist x 1
    ^ Top  
  11. Indranys Learned

    Indranys
    Joined:
    Nov 24, 2012
    Parrots:
    457
    Location:
    Illepsum
    Damn guys I got the problem too, tried every stuff in those posts but nothing's worked.
    But Crom be thanked, at least I find a decent solution for myself.
    The shiets I've done:
    >DL DxWnd here and install da biatch.
    >Run it as admin, then edit -> add and just add the name and teudogar.exe's path. Edit the resolution as you see fit, just don't set it too big or the game will hang.
    >Save the changes, left click twice to run the game.
    >Profit. :cool:

    Maybe not the best solution around 'cause we can't play the game on fullscreen with this shit, but it's pretty serviceable for me nonetheless.
    Please do tell me if you bros find a better setting for DxWnd or any superior fix. :salute:
     
    ^ Top  
  12. azerty Novice

    azerty
    Joined:
    Jan 20, 2014
    Parrots:
    23
    Simple solution that works for my computer :)
    Options>Graphics and scrolling> change "graphic data" from fast to slow or slow to fast :)
     
    ^ Top  

(buying stuff via the above buttons helps us pay the hosting bills, thanks!)